Forms Application does not run anymore after java upgrade to 1.8_131 on client

If Your Forms application cannot be started after a java upgrade to 1.8_131, please check this Oracle Community Thread: https://community.oracle.com/thread/4037666

In short:
Reason is: Java 8u131, MD5-hashes are no longer accepted in certificates
If using Forms 12c, no action has to be taken - if using Forms 11 you'll have to apply patch 19933795

Quick fix (not recommended!): Adapt the appropriate java.security file line
jdk.jar.disabledAlgorithms=MD2, MD5, RSA keySize < 1024
to
jdk.jar.disabledAlgorithms=MD2, RSA keySize < 1024


Coming up next: ODA X4 – migrating a database from ASM to ACFS

When using oakcli 12.1.2.7.0, a 'create database' command will create the database on ACFS ... except for databases of version lower than 11.2.0.4. Those databases are created on ASM. So, instead of dropping and recreating a database, You could 'simply' migrate from ASM to ACFS. The comming post will describe the 'how-to' and the necessary steps to do so.



Starting and Stopping Domains Using WLST – The Easy Way

Yes - another post 'how to start/stop a domain using WLST' ... But, with this scripts You only have to provide information about the nodemanager and the AdminServer. All other information used to start the domain is collected dynamically during runtime.

The tool will start or stop the nodemanager (domain- or host-based), the AdminServer and each ManagedServer. Before starting or stopping a component a check is done if the operation in question is possible or not. (more...)

First Blog Post …

Yes - yet another blog related to Oracle Database and Fusion Middleware stuff ...

Nevertheless, possibly, You'll find useful information to ease Your daily business, how to's to solve problems or to workaround 'unwanted features'.

Feel free to comment my blog posts or to present own solutions (for example by link in Your own blog posts)

Robert